Rightmost Digit

题目链接
Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.


在维基百科查到这样一段代码:

1
2
3
4
5
6
7
8
9
10
11
12
double power (double a, unsigned int n)
{
double y = 1;
double f = a;
unsigned int k = n;
while (k != 0) {
if (k % 2 == 1) y *= f;
k >>= 1;
f *= f;
}
return y;
}

当 a=n=5时:

5 2 1
5^2 5^4

当a=n=8时:

8 4 2 1
8^2 8^4 8^8

这个算法真的达到了指数级增长,时间复杂度仅为O(log n ),代码优美.

由此修改就可得到AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include<cstdio>
#include<iostream>
#include<math.h>
#include<algorithm>

using namespace std;

int myPow(int a, int n)
{
int k = n;
int x = a % 10, y = 1;
while(k != 0)
{
if(k % 2 == 1)
{
y = (y * x) % 10;
}
x = (x * x) % 10;
k >>= 1;
}
return y;
}

int main()
{
int t, y;
scanf("%d", &t);
while(t--)
{
scanf("%d", &y);
printf("%d\n", myPow(y, y));
}

return 0;
}