字符串比较

题目链接
开门人和关门人

Problem Description
每天第一个到机房的人要把门打开,最后一个离开的人要把门关好。现有一堆杂乱的机房签
到、签离记录,请根据记录找出当天开门和关门的人。

Input
测试输入的第一行给出记录的总天数N ( > 0 )。下面列出了N天的记录。
每天的记录在第一行给出记录的条目数M ( > 0 ),下面是M行,每行的格式为

证件号码 签到时间 签离时间

其中时间按“小时:分钟:秒钟”(各占2位)给出,证件号码是长度不超过15的字符串。

Output
对每一天的记录输出1行,即当天开门和关门人的证件号码,中间用1空格分隔。
注意:在裁判的标准测试输入中,所有记录保证完整,每个人的签到时间在签离时间之前,
且没有多人同时签到或者签离的情况。

Sample Input
3
1
ME3021112225321 00:00:00 23:59:59
2
EE301218 08:05:35 20:56:35
MA301134 12:35:45 21:40:42
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output
ME3021112225321 ME3021112225321
EE301218 MA301134
SC3021234 CS301133


strcmp(s1, s2) 返回int;若s1>s2则 int>0;s1<s2则int<0;

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

int main()
{
char fn[15],ln[15],card[15],ft[8],lt[8],in[8],out[8];
int t, n;
scanf("%d", &t);
while(t--)
{
strcpy(lt,"00:00:00");
strcpy(ft,"23:59:59");
scanf("%d", &n);
while(n--)
{
scanf("%s %s %s", &card, &in, &out);
if(strcmp(ft, in) >= 0)
{
strcpy(ft, in);
strcpy(fn, card);
}
if(strcmp(out, lt) >= 0)
{
strcpy(lt, out);
strcpy(ln, card);
}
}
printf("%s %s\n", fn, ln);
}
return 0;
}